TIMER Problems Cont

Discuss whatever you want here--both QB and non-QB related. Anything from the DEF INT command to the meaning of life!

Moderators: Pete, Mods

Post Reply
RayBritton
Veteran
Posts: 109
Joined: Thu Feb 10, 2005 12:38 pm

TIMER Problems Cont

Post by RayBritton » Mon Oct 31, 2005 5:03 pm

I have this so far:

Code: Select all

guichoice$ = ""
	Seconds = 60
	CurrentTime! = TIMER
	LOCATE 1, 1
	WHILE CurrentTime! + Seconds! > TIMER OR turncomplete = 1 OR guichoice$ <> ""
			guichoice$ = INKEY$
			LOCATE 1, 1
			'PRINT TIMER; "T:"; CurrentTime! + Seconds!
		WEND
but now nothing i press anything nothing happens i need help

moneo
Veteran
Posts: 451
Joined: Tue Jun 28, 2005 7:00 pm
Location: Mexico City, Mexico

Post by moneo » Mon Oct 31, 2005 8:41 pm

Ray,
You define Seconds = 60
But then you refer to Seconds!

Change it to Seconds! = 60
then it runs fine.
*****

RayBritton
Veteran
Posts: 109
Joined: Thu Feb 10, 2005 12:38 pm

Post by RayBritton » Tue Nov 01, 2005 2:04 am

sorry about that i posted the wrong version, an didn't give much explaination into whats going wrong.

Code: Select all

	guichoice$ = ""
	Seconds! = 10
	CurrentTime! = TIMER
	smoTIME! = CurrentTime! + Seconds!
	WHILE CurrentTime! + Seconds! > TIMER OR turncomplete = 1 OR guichoice$ <> ""
			guichoice$ = INKEY$
			LOCATE 1, 1
			PRINT TIMER; "T:"; CurrentTime! + Seconds!
		WEND
	IF smoTIME! >= CurrentTime! + Seconds! THEN turncomplete = 1
	IF guichoice$ <> "" GOTO nextmove
	IF turncomplete = 1 THEN GOTO finalnextmove
the timer works fine, everything else is fine except the program doesn't recieve what i type, nothing happens when i press anything

RayBritton
Veteran
Posts: 109
Joined: Thu Feb 10, 2005 12:38 pm

Post by RayBritton » Tue Nov 01, 2005 9:46 am

don't worry i fixed now

Post Reply